News:

"The phone is a remarkably complex, simple device,
and very rarely ever needs repairs, once you fix them." - Dan/Panther

Main Menu

Wall hung rotary phone not ringing

Started by Jbern, August 22, 2022, 02:53:35 PM

Previous topic - Next topic

Jbern

The hammer is activating when a ring signal is supplied but it is barely touching the bells and makes very quiet noise. Anny suggestions welcome

HarrySmith

Try adjusting the gongs. If you notice the mounting screws are offset, not centered. Turning the gongs will bring them closer to the striker.
Harry Smith
ATCA 4434
TCI

"There is no try,
there is only
do or do not"

TelePlay

What are you using to generate the ring signal?

Are you ringing more than one phone at the same time on that line?
Yesterday eats you up, it eats everyone up . . .

poplar1

You may have to reduce the tension on the long spring.

What is the source of your ringing current (what type of line)?
"C'est pas une restauration, c'est une rénovation."--François Martin.

MMikeJBenN27

What I like to do is remove the ringer and hook it up to my "testing" 425B network,and hook up a line cord to that.  If ringer then works fine, I know the capacitor in the phone is bad. Also, a wire could be interfering with the clapper, OR a spade terminal is shorting against something metal.  You would be surprised how often I have "fixed" non-ringing phones that I bought through E-Bay this way. Adjusting the gongs and the bias spring is easier this way as well.

Mike

TelePlay

Quote from: MMikeJBenN27 on August 22, 2022, 05:09:08 PMAdjusting the gongs and the bias spring is easier this way as well.

 . . . or that AE ringer has maxed out the REN power capacity of the supply line.
Yesterday eats you up, it eats everyone up . . .

Jbern

You guys are all genius. I removed the bells and found there was a wire touching the back pf the bells as predicted. Whit the bells out of the way i saw that the tension bar was bent way up and straighted it to reduce the tension. I adjusted the lower screw to maximize the amplitude of the hammer. Then i swaped the bells for good measure and it rings perfectly.
Thanks.
By the way. I am usung a 80v signal at 20Hz from a TeleRing Ring Generator