"The phone is a remarkably complex, simple device,
and very rarely ever needs repairs, once you fix them." - Dan/Panther

Main Menu

Millennium Payphone Manager

Started by mkivtt, November 16, 2022, 06:22:06 PM

Previous topic - Next topic


Good afternoon!  I am new to the forum and I guess I will jump right in with a hot topic.  The name is Ryan and I am from Texas.  I, within the last few months, have acquired a millennium payphone.  I have setup a server (multiple attempts) with no luck.  The issue I have is with the initial modem initialization failing.  I have attempted to put in a ticket twice within the Github project but they do not appear in the issues tab.

Using the following setups:
Lenovo PC
OS: Windows 10
Modems: USR 56k V92 modems (5637 USB, and 5686E Serial) 
The USR5637 seems to get past the reset and into initialization but then fails, the serial modem does not even get to initialization before it fails.

OS: Multiple Linux distros
Modem: USR5637
Same, USR5637 seems to get past the reset and into initialization but then fails.

I have attempted using the -i to input custom initialization strings with no luck.  The command fails.  I have attempted editing the configuration files to reflect the string I wish to try, with no luck.  It just loads the original default.  I am not familiar with programming as much as I probably should be for this project, but I am not seeing any log files with worthwhile information and the verbose just gives me "Initialization failed~"

Anyone with experience on this project that can give insight would be appreciated.  I am worn out on all the projects I have collected and would like to "wrap" some up.  The wife would also appreciate it.  I have also searched for the all elusive demo firmware and come up short.  Nobody wishes to speak on the issue as if it is secret launch codes.   :(   

Thanks for any assistance in advance and I cannot wait to mount my two payphones!


I am also dealing with the exact same problem and I have the same setup as you do. I have tried several different initialization strings and the modem fails to initialize. I have been trying to troubleshoot this problem for a while now without any luck. I did notice that I can get the modem to initialize if I go off hook on the millennium and hit * on answer detect and then start MM_manger. The modem will initialize, but the phone will not interface with it. 


Hi guys. Certainly not an expert here, but thought I'd share what worked for me. Using an older laptop with an internal modem, win 10, and couldn't get the modem to initialize. I downloaded PuTTy, and connected directly to the modem com port to make sure it could dial out. Once I proved the modem was functional, I went through the initialization string with PuTTY one item at a time, ATS0=1, ATE0, ATQ0, etc , until I got to AT+MS=bell212. This is where my modem failed, as the proper syntax for this option on my modem is +MS=Bell212A. Once I corrected this in the init string, the modem intialized, and mm_manager was waiting for a call from the terminal. I went through the installation on my Millennium, and now it works! I hope this info helps get yours up and running as well!

Hill Haven Telephone Company

So a few years back I did a video on Millennium Manager and using it with the USR modems

i just reuploaded it.  Shows how to configure it with USR Serial modems



Thank you. Great vid. Wish I'd seen this about 18 months ago, I might still have hair. lol. Just an observation, this procedure is for mm_manager ver 0.5. In the new version 0.8 the initialization string is moved into a command line argument. It uses -i with the init string items in double quotes. ie -i "ATS0-1 +MS=Bell212A"
I've got raspberry pis running on both versions now and just successfully set up on a windows machine as well. Great hobby. Good to see a few of these Millenniums escape the landfill/recyclers.