Telephone Switching > VOIP, Asterisk, C*NET, NPSTN, XLink, etc

Need older windows software Vista/7 for xlink

(1/1)

markosjal:
Does anyone have older versions of xlink software for Vista or 7??  An old win10 version might work . Can someone please send to markosjal at the mail with a G

Navigation

[0] Message Index

Go to full version