"The phone is a remarkably complex, simple device,
and very rarely ever needs repairs, once you fix them." - Dan/Panther

Main Menu

Allen Tel GB5955 issues

Started by Tribune, April 06, 2018, 08:01:29 PM

Previous topic - Next topic


Hi there

My first time back on the forum in probably five years or more! Phone collection has taken a back seat while life got in the way. Glad to be back.

Anyway, I've an issue with an Allen Tel Products GB5955 weatherproof phone that I purchased unused a few years ago. Unit is basically composed of ITT components: rotary dial, printed circuit board network, single gong two-wire ringer. Phone dates, according to numbers on components and label inside, to 1993.

The phone rings - with the hook switch in both off and on positions. No dial tone from the handset, only noisy clicks when the hook switch is raised and depressed. I wanted to check that it is wired correctly before contemplating replacing the network. However, I can't find a wiring diagram for the phone though I've looked on the TCI website and various other sources.  Also checked available ITT schematics as well.

I've attached a diagram of how the phone is currently wired (as it was when purchased). Can anyone on the forum say if this set up should work? And if it doesn't work, would would be the correct wiring?

Many thanks,
Mark Furze - TCI, ATCA

To miss-quote "Bones" McCoy . . .
                     "darn it Jim - I'm a doctor, not a telephone engineer!"


Move red hookswitch wire from E3 to L1.

E3 is a blind terminal -- it doesn't connect to anything inside the network.
"C'est pas une restauration, c'est une rénovation."--François Martin.


Thanks poplar1.

Tried your suggestion, but still the same. Rings with hook raised or depressed, no dial tone, no sound from handset whatsoever aside from clicks when hook switch manipulated. Does not ring out.  :-[

So I tried the alternative set-up (see attached) after studying a bunch of ITT schematics. Rings, still no dial tone, but the open line hum from the handset. And suggestions on this set up, or am I likely looking at a faulty connection or faulty network somewhere?

Mark Furze - TCI, ATCA

To miss-quote "Bones" McCoy . . .
                     "darn it Jim - I'm a doctor, not a telephone engineer!"


Have you checked the continuity of the switch and tip/ ring inputs. The network is not getting power, so you need to try jumping from tip to rr on the network, and then ring to c on network. Those give direct connection to the network do you get handset function? If so, work back from either tip or ring connections and note when it fails. It could be as simple as the dial contact isn't connecting tip to f or r on the network.