Author Topic: Forum Software Update  (Read 17912 times)

Offline AE_Collector

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7504
  • AE 2 - AECo's 1st Self Contained Desk Phone 1925
Re: Forum Software Update
« Reply #15 on: December 21, 2013, 10:17:38 PM »
(and it's still there as far as I can see!)... :D

Not for me using IE, just a red X in a box like many others as well.

Terry

Offline twocvbloke

  • Hero Member
  • *****
  • Posts: 4503
  • W.E. 500 DM
Re: Forum Software Update
« Reply #16 on: December 21, 2013, 10:25:55 PM »
Not for me using IE, just a red X in a box like many others as well.

Terry

Try pressing the Ctrl and F5, this will flush out the cache to update what IE can't be bothered to reload post-update... :)

Then go and download a decent browser... :D

Offline Dennis Markham

  • VintageRotaryPhones.com
  • Administrator
  • Hero Member
  • *****
  • Posts: 5610
    • VintageRotaryPhones.com
Re: Forum Software Update
« Reply #17 on: December 22, 2013, 01:41:11 AM »
Here's where we are at the moment.  The "theme" was changed to bring things back in line.  Obviously things look much different.  The little Model 302 icons are gone as is the banner at the top of the page.  Things that will be modified in the near future.  But meantime, I think things should be working normally.  It's just a matter of getting used to the current changes. 

I will keep everyone updated as I (we) move forward from this upgrade.  It may be one of those times that we say "if it ain't broke, don't fix it".

Dennis

Offline Dave Zemens

  • *
  • Posts: 64
    • 1955 Design
Re: Forum Software Update
« Reply #18 on: December 22, 2013, 05:55:28 AM »
Hello Everyone,

Dennis asked me to update the software that runs this forum because apparently there were some enhancements in the new software that were beneficial to how the forum functions. Although I'm fairly computer savvy, I had no previous experience with the Simple Machines software that runs this website.

Yesterday evening I did a backup of the full website and installed the update. Things went smoothly and the software advised me that every step of the way the upgrade went fine resulting in a successful upgrade to the current version of the software.

It became immediately apparent that things just didn't "look right" after the upgrade in terms of page layout, missing data, etc. My review of the problems led me to believe that the current theme (the visual interface of the forum - not the data itself) was not compatible with the new version of the software. So I modified the theme to what you see now and it appears to me that things are now working properly. By that I mean it appears that all of the data from the back end database is being properly rendered on the screen.

I understand that the look and feel of the forum is different. Based on the fact that the previous theme is no longer compatible, moving forward from here it's apparent that the forum is going to look different. What that final look turns out to be is something Dennis will have to decide.

Your comments about the new theme / upgrade are important to me, but in my mind I separate them into two different areas:

1) Comments about "What's not working or missing" (Most important)
2) Comments about "I don't like this or that" (Less important)

From what I have read there are suggestions that photographs are missing after the upgrade. It appears to me that all photos are working as in the past.  I see dozens and dozens of photos and have yet to see a broken link indicating a missing photo.

Someone else suggested that avatars are missing.  My avatar is right where it always was and I did not have to add or modify my account in any way.  I think some issues may be related to "cache" and each user might have to clear their browser cache and cookies to see the new upgrade properly. If you don't know how to do that you can Google it for your particular browser and you'll learn how to easily clear both the cache and the cookies of your browser.

Others have suggested that some of the editing features when writing or replying to posts are missing. I see all standard editing features while I am writing this post - actually, there's so many features that I think most of them just garbage up the actual posts - but that's my opinion and yors may be different. But to me, all normal editing features are present with the current theme that is being used.

So...I'll try to review this post for the next few days to see what other comments are made, and I'll work with Dennis to make things just how he wants them if it is possible to do so. But remember that whatever the end result is won't be how the forum "looked and felt" before.

I'm just glad the tens of thousands of users and posts didn't get blown up during the upgrade and that all the *data* is still here!

- Dave Zemens
Dave Zemens
1955 Design | Rochester, Michigan
Website Design & Development
Custom WordPress Themes & Plugins

Offline DavePEI

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4004
  • Telephone Museum of Prince Edward Island
    • The Telephone Museum of Prince Edward Island
Re: Forum Software Update
« Reply #19 on: December 22, 2013, 08:38:28 AM »
Hi Dave:

Things are looking different, but good. So far, at least, it looks as though all the data is there, and the message options/smilies are there again. Of course, it has only been back on a few minutes, and it will take a while to find any bugs, but it is looking better than last night.

Thanks to you and to Dennis for taking on this chore - it is much appreciated. From my own web experience over the past 20 years, I know how tricky upgrades can be. I know that heart in the mouth feeling waiting to see is all is still there when the upgrade is done. So, you can swallow it again, things are looking pretty good, and if anything is still worng and awaiting discovery, I am sure it will work out ok.

I agree with you - it was the Theme which didn't appear to be compatible with the newer software... Thanks for taking on this chore. We appreciate it, and I know Dennis does, too!

Dave
The Telephone Museum of Prince Edward Island:
http://www.islandregister.com/phones/museum.html
Free Admission - Call (902) 651-2762 to arrange a visit!
C*NET 1-651-0001

Offline Dave Zemens

  • *
  • Posts: 64
    • 1955 Design
Re: Forum Software Update
« Reply #20 on: December 22, 2013, 08:44:01 AM »
@Dave in PEI:  Thanks for the comments. Much appreciated. Things do look pretty good at the moment. I'm quite certain all the functionality is in place just as before. Only difference is the look and feel. To be honest, I like the new theme better, but I'm not as used to the old theme as you regulars were.
Dave Zemens
1955 Design | Rochester, Michigan
Website Design & Development
Custom WordPress Themes & Plugins

Offline DavePEI

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4004
  • Telephone Museum of Prince Edward Island
    • The Telephone Museum of Prince Edward Island
Re: Forum Software Update
« Reply #21 on: December 22, 2013, 08:46:24 AM »
@Dave in PEI:  Thanks for the comments. Much appreciated. Things do look pretty good at the moment. I'm quite certain all the functionality is in place just as before. Only difference is the look and feel. To be honest, I like the new theme better, but I'm not as used to the old theme as you regulars were.
Yes, it is going to take a while to get used to it, but it is functional. I just noticed one change - the messages notification is no longer on the main page - the notification of PMs for a member. It used to be above the topic lists...

Dave
The Telephone Museum of Prince Edward Island:
http://www.islandregister.com/phones/museum.html
Free Admission - Call (902) 651-2762 to arrange a visit!
C*NET 1-651-0001

Offline Dave Zemens

  • *
  • Posts: 64
    • 1955 Design
Re: Forum Software Update
« Reply #22 on: December 22, 2013, 08:57:38 AM »
Yes, it looks like the private message notification now shows up in the horizontal menu with an indicator of how many messages you have waiting to be read.  Different, but functional!   :P
Dave Zemens
1955 Design | Rochester, Michigan
Website Design & Development
Custom WordPress Themes & Plugins

Offline DavePEI

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4004
  • Telephone Museum of Prince Edward Island
    • The Telephone Museum of Prince Edward Island
Re: Forum Software Update
« Reply #23 on: December 22, 2013, 09:12:03 AM »
I should point out to other users, if you don't like the new last to first method of listing messages, you can change that in your profile settings. Likewise, you can shut off the quick editor there if you don't like it....

Everything is looking different, but fantastic!

Dave
The Telephone Museum of Prince Edward Island:
http://www.islandregister.com/phones/museum.html
Free Admission - Call (902) 651-2762 to arrange a visit!
C*NET 1-651-0001

Offline Bridie

  • ***
  • Posts: 130
Re: Forum Software Update
« Reply #24 on: December 22, 2013, 09:18:21 AM »
It's looking fab.  The only thing I didn't like was the most recent posts displaying first, but I changed that easily in my Profile > Account settings.  I'm not having any issues here, using Google Chrome.


Many thanks for creating and maintaining this forum - it's been a huge source of assistance for me.


Bridget
Bridget

Offline Dave Zemens

  • *
  • Posts: 64
    • 1955 Design
Re: Forum Software Update
« Reply #25 on: December 22, 2013, 09:25:31 AM »
Based on previous comments I *believe* that I change the default theme settings to show posts in the order of first -> last which is apparently how the old theme handled them.

I *believe* that I also removed the default setting of "Quick Reply" for post replies as well.

Let me know.
Dave Zemens
1955 Design | Rochester, Michigan
Website Design & Development
Custom WordPress Themes & Plugins

Offline DavePEI

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4004
  • Telephone Museum of Prince Edward Island
    • The Telephone Museum of Prince Edward Island
Re: Forum Software Update
« Reply #26 on: December 22, 2013, 09:35:06 AM »
Hi Dave:

I think most used first to last, but there were some who preferred last to first. As far as the quick editor is concerned, I hadn't yet made up my mind whether I liked it, but it would serve the purpose of reducing the amount of quoting used on the fortune.

You might want to turn them both on again, and let the users decide for themselves which they prefer - everyone has different likes and dislikes.

I an sure the odd problem may show up, but overall, it is excellent. I am sure it was nerve wracking for you and for Dennis!

Dave
« Last Edit: December 22, 2013, 09:37:14 AM by DavePEI »
The Telephone Museum of Prince Edward Island:
http://www.islandregister.com/phones/museum.html
Free Admission - Call (902) 651-2762 to arrange a visit!
C*NET 1-651-0001

Offline Dave Zemens

  • *
  • Posts: 64
    • 1955 Design
Re: Forum Software Update
« Reply #27 on: December 22, 2013, 09:38:08 AM »
I believe you are correct Dave. I set them back to the defaults of "Most recent post shown first" and "Quick Reply on". Both can be controlled by individual users in their own profiles.
Dave Zemens
1955 Design | Rochester, Michigan
Website Design & Development
Custom WordPress Themes & Plugins

Offline dsk

  • Hero Member
  • *****
  • Posts: 3539
Re: Forum Software Update
« Reply #28 on: December 22, 2013, 09:57:13 AM »
 8) We resist every change by nature, but this really looks to be better, just not familiar with it yet, different colors etc.
 :) You have done a great job!

dsk

I have even got a regular New York number :-) 646 570 1796

Offline Contempra

  • Hero Member
  • *****
  • Posts: 928
Re: Forum Software Update
« Reply #29 on: December 22, 2013, 10:27:07 AM »
Well, this is a big change of your forum Dennis !
Denis