Author Topic: Telrad 215-50 not dialing  (Read 81 times)

Offline Telavi12

  • *
  • Posts: 7
Telrad 215-50 not dialing
« on: March 17, 2019, 01:50:49 AM »
Hello all
I’m new to this fabulous forum and I hope you’ll be able to help.
I got a 1985 Telrad rotary phone model 215-50
I tried to connect it to the telephone line but it seems the rotary dial does not work, it moves but does not send pulses to the line that generates a call.
I get a line signal, the ringer is working, I can receive calls, cradle switch is OK but dialing does not work. When the dial is rotated the dialing tone goes away but no connection is made.
What I did while trying to fix it:
1. First I checked the line with another phone to verify that pulse dialing is working on this line.
2. I opened the rotary dial, cleaned it, cleaned the governor, cleaned the ‘relays’ contacts.
Everything is moving/rotating smoothly. But no pulses are sent or sent incorrectly.
3. I cleaned the dial’s connector and 5 pins.
Does anyone have any idea what might cause this matter and how to fix it?
How do I verify that the dial is working OK? Is there a way to test it with a multimeter?
Many thanks

Attached schematics of this phone and images of its components.

Offline tubaman

  • *
  • Posts: 320
Re: Telrad 215-50 not dialing
« Reply #1 on: March 17, 2019, 05:49:09 AM »
Welcome to the forum Telavi12.

Your phone is clearly based on a GPO 746 with a modified circuit board.
That's a GPO No 21 type dial so D1 - D5 on your circuit diagram go with the screw points going left to right in your picture of the dial.
I would be checking that the dial connection wires are going to the right screws on the dial to start with. My suspicion is that the dial wiring has been messed about with as these dials are pretty reliable.
You can test it with a multimeter - the screws going 1 -5 (left to right)coincide with the contacts going in the opposite direction (right to left) if that makes sense.
You should be able to visually see the pulse springs working - they are the two contacts on the left of your picture.
 :)
 

Offline LarryInMichigan

  • **
  • Posts: 4979
Re: Telrad 215-50 not dialing
« Reply #2 on: March 17, 2019, 07:07:58 AM »
If the dial is breaking dial tone but not dialing correctly to make a call, it could be that the pulsing contacts are not opening for the proper amount of time, or they are not opening and closing at the proper speed.  The contacts may be open too long or not long enough or opening and closing too quickly or slowly.  For GPO dials, I think that the make-break ratio is supposed to be 33%/67%, and the speed should 10 pulses per second.  If you have an oscilloscope, you could check these.  You can change the make/break ratio by slightly bending the thick contact on the inner left of your picture to the left or right.

!ﬣצלחה


Larry

Offline Telavi12

  • *
  • Posts: 7
Re: Telrad 215-50 not dialing
« Reply #3 on: March 17, 2019, 07:23:01 AM »
Thank you @tubaman for your quick reply.
I double checked all dial wires going from the dial to P1 connector and all are OK and according to the diagram which says: D1-Blue to P1-4, D2-Gray to P1-3, D3-Brown to P1-2, D4-Pink to P1-5 and D5-Orange to P1-1.
I also looked and tested the PCB print side and all leads are OK.
Any idea what to test next?
Thanks



Offline Telavi12

  • *
  • Posts: 7
Re: Telrad 215-50 not dialing
« Reply #4 on: March 17, 2019, 07:29:31 AM »
Thanks @ LarryInMichigan
I’ll try and play with it. Do you mean contact #5 (Red number)?
Thanks

Offline tubaman

  • *
  • Posts: 320
Re: Telrad 215-50 not dialing
« Reply #5 on: March 17, 2019, 07:32:16 AM »
Is it actually breaking the dial tone when you dial? The dial in the picture certainly looks like it should work unless the speed is a long way out.
I don't know how tolerant your exchange is to dial speed - in the UK they have to be a very long way out before they stop working!
Before trying to adjust anything can you confirm that contacts 4 and 5 in your picture do pulse when the dial is operated.
 :)

Offline Telavi12

  • *
  • Posts: 7
Re: Telrad 215-50 not dialing
« Reply #6 on: March 17, 2019, 07:41:18 AM »
I tested contacts 4 and 5 with a multimeter and while dialing the resistance is changing
And yes, after starting a dial the line tone is breaking

Offline tubaman

  • *
  • Posts: 320
Re: Telrad 215-50 not dialing
« Reply #7 on: March 17, 2019, 08:08:23 AM »
It's sounding like the speed is out - it should take a fraction over 1 second to return when dialling a 0.
You can adjust the speed by very gently adjusting the governor weights, but it's not usual for these to be far out unless they have been messed with.
You say that the resistance between 4 and 5 changes when dialling so it sounds like it's pulsing. If you let the dial slowly return by hand I assume you can see the contacts opening and closing (there should be a visible air gap between them on each pulse).
 :)

Offline Telavi12

  • *
  • Posts: 7
Re: Telrad 215-50 not dialing - problem solved
« Reply #8 on: March 17, 2019, 09:13:44 AM »
Hurray ! problem solved !

I bent contact #5 and this solved the matter.
I first bent it towards contact #4 and the dial tone didn’t go off at all while dialing, then I bent it to the opposite side (opened it) and voila,  the dialer is working, accurately as expected.

Many thanks guys for your tips and help, I only miss now a redial button…  :) ;D :)

Offline tubaman

  • *
  • Posts: 320
Re: Telrad 215-50 not dialing
« Reply #9 on: March 17, 2019, 09:31:18 AM »
Excellent!
Sounds like the contacts weren't opening quite far enough.
 ;D

Offline LarryInMichigan

  • **
  • Posts: 4979
Re: Telrad 215-50 not dialing
« Reply #10 on: March 17, 2019, 10:24:03 AM »
Hurray ! problem solved !

I bent contact #5 and this solved the matter.
I first bent it towards contact #4 and the dial tone didn’t go off at all while dialing, then I bent it to the opposite side (opened it) and voila,  the dialer is working, accurately as expected.

Many thanks guys for your tips and help, I only miss now a redial button…  :) ;D :)


That was my first guess.  I have had many phones which didn't dial properly because the pulsing contacts were too close together or too far apart.  My telephone exchange seems to be somewhat particular about that.


Larry

Offline Telavi12

  • *
  • Posts: 7
Re: Telrad 215-50 not dialing
« Reply #11 on: March 17, 2019, 10:41:30 AM »
Thanks Larry

you were right about the fix. thanks
No idea what caused it as the dialer is looking clean and as new... I guess time has its impact even on those robust products.

Thanks mate