Author Topic: Problems with Linksys SPA 3102  (Read 1781 times)

Offline dsk

  • **
  • Posts: 4194
Problems with Linksys SPA 3102
« on: April 07, 2013, 07:41:10 AM »
Hi
For some time I have had trouble with receiving calls at the Line 1

I made a factory reset, and it didn't help. When a registry timer reach 0 (once a minute) I get a reorder tone. The other end may sometimes still hear me for some time.

Is it any "experts" there to help me?

Link to my setup: (PDF)   http://www.scribd.com/doc/134482133/Trouble-with-my-SPA-3102

Thank you!

dsk
« Last Edit: April 07, 2013, 08:41:29 AM by dsk »

Offline AE_Collector

  • Global Moderator
  • *****
  • Posts: 7527
  • AE 2 - AECo's 1st Self Contained Desk Phone 1925
Re: Problems with Linksys SPA 3102
« Reply #1 on: April 07, 2013, 04:08:05 PM »
Uh Oh.....we all thought that YOU were the expert dsk. What I do know is that it ISN'T ME. Anyone?

Terry

unbeldi

  • Guest
Re: Problems with Linksys SPA 3102
« Reply #2 on: April 08, 2013, 12:37:19 AM »
If I recall the 3102 has one FXS and one FXO port.
I think, this would greatly depend also on the SIP server where the ATA is provisioned.
It appears the endpoint is registered. Perhaps you should troubleshoot this with the provider, since they can see the logs on the server.

Offline dsk

  • **
  • Posts: 4194
Re: Problems with Linksys SPA 3102
« Reply #3 on: April 08, 2013, 02:20:52 AM »
I got some hints about the NAT settings, It looks like problem is solved, more info to come after some real testing.

Testing with:

Under the PSTN tab, set 'NAT Mapping Enable' to YES, and set
'NAT Keep Alive Enable' to YES.
Undes Sip tab: Handle VIA received: Yes, Handle VIA received: YesSubstitute VIA Addr: Yes


dsk

Offline dsk

  • **
  • Posts: 4194
Re: Problems with Linksys SPA 3102
« Reply #4 on: April 09, 2013, 03:36:48 AM »
Maybe not solved  >:(
I got problems registering with the new setting.

So for the moment I went back to the setting from the start, I stopped forwarding to gw0 and put in an anti tinkle device http://www.classicrotaryphones.com/forum/index.php?topic=9178.msg98236#msg98236
at the telephone cord.

I have to take brake from this for some days, but it works as it is now, but not as I wanted.  :(
dsk

unbeldi

  • Guest
Re: Problems with Linksys SPA 3102
« Reply #5 on: April 10, 2013, 02:35:54 AM »
Maybe not solved  >:(
I got problems registering with the new setting.

So for the moment I went back to the setting from the start, I stopped forwarding to gw0 and put in an anti tinkle device http://www.classicrotaryphones.com/forum/index.php?topic=9178.msg98236#msg98236
at the telephone cord.

I have to take brake from this for some days, but it works as it is now, but not as I wanted.  :(
dsk

Oh, I just discovered more pages of that PDF...
Seems like you're behind a NAT, and this sounds indeed like a NAT problem.
Try setting the REGISTER expiration to 90 or 120 seconds, rather than the 3600 (1 hour). This serves as a built-in NAT-keep-alive mechanism without additional overhead. Typical NAT UDP binding timeouts are around 2 minutes, perhaps a little longer. If you're on a dynamic IP address ISP, then it also helps adjusting to that more quickly. Turn off all other NAT traversal methods to start, especially SIP OPTIONS or NOTIFY, perhaps the provider doesn't like it and ignores them or blocks your traffic even; pretty common, btw.  Oh, SIP2SIP I think even tells you to do so as they have there own p2p NAT traversal scheme with DHT.
Other than that, I think you should look carefully at the device logs and/or capture a SIP trace.